Service ‘Director Windows Management Instrumentation Provider’ failed to start.


Environment

  • Citrix XenApp 6.5 RU2-5
  • Microsoft Windows Server 2008 R2 SP1

Issue

Installing ‘Director Windows Management Instrumentation Provider’ (DirectorWMIProvider_x64.msi) onto Citrix XenApp 6.5, the component installs but then fails starting the service.

Resolutions

  • Recommend Fix:

Ensure the latest Microsoft Root Certificate has been applied – http://support.microsoft.com/en-us/kb/3004394 then install DirectorWMIProvider_x64.msi (ideal fix), the service will now start during install.

  • Alternate Workaround:

Enable “Turn off Automatic Root Certificate Update” in GPO under Computer Settings / Administrative Templates / System / Internet Communication Management, then install DirectorWMIProvider_x64.msi (this fix isn’t ideal but works, you might experience issues browsing to https sites of the latest Root Cert Update hasn’t been applied. Recommend to install KB970067 also, this hotfix resolves issues with high CPU for Wmiprvse.exe on Terminal Servers running Windows Server 2008.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: