“Please wait for User Profile Services” – Logon delay


Environment

  • Windows Server 2008 R2
  • Citrix XenApp 6.5 RU5

Issue

During users logon to XenApp published applications and published desktops there can be a lengthy delay on “Please wait for the User Profile Services”, it can hang on this for up to 30 secs.

Solution

In the Group Policy Management browse to:

  • Computer Configuration
    • Administrative Templates
      • System
        • User Profiles

Modify the policy setting “Set maximum wait time for the network if a user has a roaming user profile or remote home directory” to “Enabled” and set the value Wait for network for maximum (seconds) to 0.

Advertisements

3 Responses to “Please wait for User Profile Services” – Logon delay

  1. Benjamin says:

    Great! This even resolved my problem on a new Citrix 7.15 on a TS 2016 including WEM and FSLogix. I think the problem appeared after the Citrix WEM Agent installation. Thanks

  2. Pingback: Detailed Change Log – Carl Stalhood

  3. Yaasin says:

    Thank you thank you thank you – running windows server 2016 Xenap 7.15 and bam! logins down from 60 – 80 seconds to 5 seconds

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: