Error 1603 when installing XenApp Software


Issue:

When your trying to install XenApp, hotfixes, rollups etc. Windows displays an error message with Error Code: 1603

Cause:

There has previously been an msi installer that didnt install or uninstall correctly

Resolution:

Browse to: HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress

Delete the key *.ipi

Restart the server, then try the installation again.

Advertisements

Error: “The remote server failed to execute the application launch request”


Environment

  • Windows 2008 Server R2
  • Citrix XenApp 6.5
  • Citrix Web Interface 5.4

Issue

  • Workstations using the PNAgent\Receiver are getting the following error:

 “The remote server failed to execute the application launch request. Please contact your administrator for further details”

                     ” Citrix Receiver could not contact the server. Please check your network connection”

  • Workstations browsing to the Citrix Web Interface site are getting the following error:

 “An authentication error occurred”

  • On the Citrix Web Interface server the following errors are present in the Event Viewer.

                      Site path: C:\inetpub\wwwroot\Citrix\PNAgent.

                     All the Citrix XML Services configured for farm (farm name) failed to respond to this XML Service transaction. [Unique Log ID: 8d3053f4]

Resolution

On the Citrix Web Interface, modify the XML Port from 80 to 8080

Outlook 2010 Search – No Search Results returned


Environment

Windows Server 2008 with Terminal Services

XenApp5

Microsoft Office 2010 SP1

Symptoms

You open Outlook 2010 in a Remote Desktop Protocol (RDP) session on a computer that is running Windows Server 2008. When you try to search a string that is included in some email messages in Outlook 2010, no search results are returned.

Resolution

Apply ‘Outlook 2010 Hotfix‘ August 30, 2011

Citrix Web Interface – Citrix Servers are not licensed to support Workspace Control


Environment

  • Windows 2008 Server SP2
  • Citrix XenApp 5 Rollup1
  • Citrix Web Interface 5.4

Issue

  • On the Citrix Web Interface server the following errors are present in the Event Viewer.

Event ID: 31007

Site path: C:\inetpub\wwwroot\Citrix\PNAgent.

The Citrix servers are not licensed to support workspace control. This message was reported from the XML Service at address http://(XML Server)/scripts/wpnbr.dll

  • On the Server mentioned above (XMLServer) the following errors are present in the Event Viewer

Event ID: 9014

The licenses required by this edition of Citrix XenApp are not present on the license server (License Server).

Resolution

Check the server mentioned in the Event Viewer, change the license (Set server edition) within the Access Management Console to something else, reboot then change it back to what it should be, reboot again. Issue should be resolved.

Citrix Web Interface – Error Enumerating a User’s Resources


Environment

Windows 2008 Server SP2

Citrix XenApp 5 Rollup1

Citrix Web Interface 5.4

Issue

On the Citrix Web Interface server the following errors are present in the Event Viewer.

Event ID: 40001

“Site path: C:\inetpub\wwwroot\Citrix\PNAgent

An error occurred while enumerating a user’s resources. An unrecognized XML messages was received from a user device.”

Resolution

Check for any recent added published applications that contain the character ‘&’.

Removing this character will remove these errors from the Event Viewer.

Slow printing in Citrix XenApp environment


Environment

Print Server – Windows Server 2008 R2

XenApp Servers – Windows Server 2008\XenApp5

  • Ensure that the Printer driver version number is the same on the Print Server and on the XenApp server
  • If the printers are MFD, make sure Spooling is happening on the printers Hard Disk. This is set on the Print Device itself
  • Disable ‘Enable Advanced Printing Features’ on the printer queue, under the Advanced tab
  • If PDF’s are spooling to 10x the file size, change the ‘Image Compression’ option from Standard to Photo (if it exists in the driver)

“Shadow Failed. Error code 0 (Error 0 – The Operation completed successfully.)”


Environment

Windows Server 2008 with Terminal Services

Citrix XenApp5

Issue

When non-admins are trying to shadow users across servers the following error displays:

“Shadow Failed. Error code 0 (Error 0 – The Operation completed successfully.)”

Resolution

Open Terminal Services Configuration

Right Click on ICA-TCP under connections and select Properties
Go to Security Tab , make sure the group in question has following permissions (Edit Special permissions)

  • Query Information
  • Remote Control
  • Logon

NOTE: Be sure to restart the server after making the above changes