XenApp hotfixes not showing in AppCenter


Issue

On some XenApp servers it might not show the installed XenApp hotfixes in the AppCenter console if though they have been installed and are showing in Control Panel > Programs and Features

Resolution

  1. Run dsmaint recratelhc on the affected servers
  2. Close and open AppCenter you will see the hotfix applied.
Advertisements

Error: Shadow failed. Error code 120


Issue

When trying to shadow users with multi-monitors you get an Error Code 120.

Resolution

There is no Citrix resolution for this, it’s a Microsoft RDS issue which effects XenApp shadowing (http://support.microsoft.com/kb/2484290)

Microsoft workaround for this is to install Remote Assistance and use this tool for Shadowing (http://support.citrix.com/article/CTX125693)

Citrix XenApp Policies – Slow to browse for WorkerGroups


Issue

When creating a XenApp policy within AppCenter and applying it to a WorkerGroup it’s very slow after clicking Browse to bring up the list of WorkerGroups.

Resolution

Create a new text file name called Citrix.XenApp.Commands.Remoting.Service.exe.config in C:\Program Files\Citrix\XenApp Commands with following:

<?xml version=”1.0″ encoding=”utf-8″?>
<configuration>
<runtime>
<generatePublisherEvidence enabled=”false” />
</runtime>
</configuration>

and start/restart the ‘Citrix XenApp Commands Remoting’ service

Updated Citrix Visio Stencils


http://blogs.citrix.com/2010/10/12/citrix-networking-visio-stencil-set/

Error 1603 when installing XenApp Software


Issue:

When your trying to install XenApp, hotfixes, rollups etc. Windows displays an error message with Error Code: 1603

Cause:

There has previously been an msi installer that didnt install or uninstall correctly

Resolution:

Browse to: HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Installer\InProgress

Delete the key *.ipi

Restart the server, then try the installation again.

Error: “The remote server failed to execute the application launch request”


Environment

  • Windows 2008 Server R2
  • Citrix XenApp 6.5
  • Citrix Web Interface 5.4

Issue

  • Workstations using the PNAgent\Receiver are getting the following error:

 “The remote server failed to execute the application launch request. Please contact your administrator for further details”

                     ” Citrix Receiver could not contact the server. Please check your network connection”

  • Workstations browsing to the Citrix Web Interface site are getting the following error:

 “An authentication error occurred”

  • On the Citrix Web Interface server the following errors are present in the Event Viewer.

                      Site path: C:\inetpub\wwwroot\Citrix\PNAgent.

                     All the Citrix XML Services configured for farm (farm name) failed to respond to this XML Service transaction. [Unique Log ID: 8d3053f4]

Resolution

On the Citrix Web Interface, modify the XML Port from 80 to 8080

Recommended Citrix and Microsoft Hotfixes for XenApp 6 and Windows Server 2008 R2


http://support.citrix.com/article/CTX129229 (Updated Aug 17, 2011)