NetScaler SDX – Unknown Device, not supported by Command Center


Environment:

  • Citrix NetScaler SDX appliances
  • Citrix Command Centre 5.x (and think it occurs in version 4.x also) on Windows Server 2008 R2

Issue:

While running a NetScaler SDX discovery in Command Centre the discovery fails with the following error message:

“Unknown device ; <sdx_ip_address> ; not supported by command center”

(The discovery of the NetScaler VPX instances discovered fine independently)

– Checked discovery logs and found the below error:

Troubleshooting Steps:

– Checked from the Command Centre server and was able to ping and SSH to SDX Management IP with same credentials used in the Command Centre NetScaler SDX profile.
– In the C:\Program Files (x86)\Citrix\Citrix Command Center\logs\discoveryLogs.txt log file, I could see it was trying to add the NetScaler SDX as “CBSDX” (CloudBridge SDX I assume).

  • INVENTORYERR: Device not recognized as CBSDX. SYSID null <sdx_ip_address>
  • INVENTORYERR: Exception while login to =<sdx_ip_address>
  • Localized : English : nsroot failed to login

Resolution:

Within Command Centre,

  • On the Administration tab,
  • Under Settings,
  • Click SSL Settings and then
  • Select the Enable TLSv1 option
  • Restart the Command Centre service.

NOTE: After restarting the Command Centre service and its running again, it can take a while before your able to log in again.

Check the service status in the C:\Program Files (x86)\Citrix\Citrix Command Center\logs\wrapper.log file

INFO | jvm 1 | 2016/05/23 14:47:00 | Starting up as Primary Server and correcting the Server information in the Database.
INFO | jvm 1 | 2016/05/23 14:47:00 |
INFO | jvm 1 | 2016/05/23 14:47:01 |
INFO | jvm 1 | 2016/05/23 14:47:01 | Starting Citrix Command Center “Primary” Server Modules, please wait
INFO | jvm 1 | 2016/05/23 14:47:15 |
INFO | jvm 1 | 2016/05/23 14:47:15 |
INFO | jvm 1 | 2016/05/23 14:47:15 |
INFO | jvm 1 | 2016/05/23 14:47:15 | Process : SyslogServerBE [ Started ]
INFO | jvm 1 | 2016/05/23 14:47:16 | Process : ProcessTest [ Started ]
INFO | jvm 1 | 2016/05/23 14:47:17 | Process : ShutdownDatabaseServer [ Started ]
INFO | jvm 1 | 2016/05/23 14:47:19 | Process : CLIRMIService [ Started ]

If you see a lot of [Failed] statues, restart the Command Centre server.